Unable to connect to stash when running as a service

Hi,

I run stash as a service under Windows Server 2003. I am able to access Stash homepage (http://localhost:7990/login) when in the Windows Server machine, but unable to do so on a network computer and unable to clone. I can, however, do these when I start Stash using "start-stash.bat" command.

Below is the log:

Sep 3, 2013 8:50:36 AM org.apache.catalina.startup.ClassLoaderFactory validateFile

WARNING: Problem with directory [C:\atlassian-stash-2.7.0\bin\${stash.home}\lib], exists: [false], isDirectory: [false], canRead: [false]

Sep 3, 2013 8:50:37 AM org.apache.catalina.startup.ClassLoaderFactory validateFile

WARNING: Problem with directory [C:\atlassian-stash-2.7.0\bin\${stash.home}\lib], exists: [false], isDirectory: [false], canRead: [false]

Sep 3, 2013 8:50:43 AM org.apache.catalina.core.AprLifecycleListener init

INFO: The APR based Apache Tomcat Native library which allows optimal performance in production environments was not found on the java.library.path: C:\atlassian-stash-2.7.0\lib\native;D:\Stash_Home\lib\native

Sep 3, 2013 8:50:44 AM org.apache.tomcat.util.digester.SetPropertiesRule begin

WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting property 'xmlValidation' to 'false' did not find a matching property.

Sep 3, 2013 8:50:44 AM org.apache.tomcat.util.digester.SetPropertiesRule begin

WARNING: [SetPropertiesRule]{Server/Service/Engine/Host} Setting property 'xmlNamespaceAware' to 'false' did not find a matching property.

Sep 3, 2013 8:50:47 AM org.apache.coyote.AbstractProtocol init

INFO: Initializing ProtocolHandler ["http-bio-7990"]

Sep 3, 2013 8:50:48 AM org.apache.catalina.startup.Catalina load

INFO: Initialization processed in 8589 ms

Sep 3, 2013 8:50:48 AM org.apache.catalina.core.StandardService startInternal

INFO: Starting service Catalina

Sep 3, 2013 8:50:48 AM org.apache.catalina.core.StandardEngine startInternal

INFO: Starting Servlet Engine: Apache Tomcat/7.0.40

Thanks.

Regards,

Wilbert

2 answers

1 accepted

I finally solve the problem, Windows Firewall.

also, when I check msconfig, it says that the stash service is running

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

631 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot