Stash requires git 1.7.6, but with git 1.8.2

my env as below:

[test tmp]$ more /proc/version
Linux version 2.6.32-220.23.1.el6.x86_64 (mockbuild@c6b5.bsys.dev.centos.org) (gcc version 4.4.6 20110731 (Red Hat 4.4.6-3) (GCC) )
#1 SMP Mon Jun 18 18:58:52 BST 2012

[test tmp]$ git --version
git version 1.8.2

[test tmp]$ which git
/usr/local/bin/git

[test tmp]$ java -version
java version "1.6.0_33"
Java(TM) SE Runtime Environment (build 1.6.0_33-b04)
Java HotSpot(TM) 64-Bit Server VM (build 20.8-b03, mixed mode)

[test tmp]$ perl -version
This is perl, v5.10.1 (*) built for x86_64-linux-thread-multi

first install stash,still prompt : Failed dependencies: git >= 1.7.6 is needed

1 answer

1 accepted

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

250 views 3 7
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you