Repository Hooks not working

Repository hooks API does not appear to properly configure the code required. The exmple code won't run due to missing libraries. I have looked online and the documentation appears to be all over the place.

The path is set to

import com.atlassian.bitbucket.repository.hook.*;

yet when I go to the online dock's it points to

import com.atlassian.bitbucket.hook.*;

 The project builds before the module hook is added.

1 answer

1 accepted

0 vote

Hi Ian, can you try replacing the wrong import :

import com.atlassian.bitbucket.repository.hook*;

by

import com.atlassian.bitbucket.hook.*;
import com.atlassian.bitbucket.hook.repository.*; 

 and let us know if that works for you?

Regards,

Ana

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jun 12, 2018 in Bitbucket

Do you use any Atlassian products for your personal projects?

After spinning my wheels trying to get organized enough to write a book for National Novel Writing Month (NaNoWriMo) I took my affinity for Atlassian products from my work life and decided to tr...

23,880 views 26 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you