Has anyone had windows server repeatedly blue screen after installing Stash?

I installed Stash on a Windows Server 2008 R2 according to the installation instructions and the server has been blue screening anywhere from one to five times a day since. When my system administrators looked at the memory dump they said Tomcat was the problem (CRITICAL_OBJECT_TERMINATION). I had multiple Tomcats running but as of the last crash, only the ones for JIRA and Stash were enabled. I have since disabled Stash and have not had a crash in almost 24 hours. I would like to continue using stash but can not unless I find a solution to this. I have tried both Stash 1.1.1 and 1.1.2. I am using 32bit Java 1.6.0_33 and the git linked from the installation instructions, currently Git-1.7.11-preview20120710. I have Stash running as a service as per the atlassian instructions. Thanks to anyone who might be able to help.

8 answers

1 accepted

We've identified the root cause for this problem and released Stash 1.2.4 with a fix for this.

Please see https://jira.atlassian.com/browse/STASH-2719 for the details.

Stash 1.2.4 can be downloaded from: http://www.atlassian.com/software/stash/download

Cheers,

Stefan

(stash_bsod_minidump.txt) I've experienced a similar BSOD twice on a virtual (VMware) Windows Server 2008 R2 instance running Stash as a service. The first time it happened a few hours after the initial install of Stash 1.1.1 & Git-1.7.11-preview20120620. The second time it happened a few minutes after upgrading to Stash 1.1.2 & Git 1.7.11-preview20120710. In both cases the minidump analysis (attached) indicates that the crash happened in the Tomcat process but it doesn't say where exactly. I'm using a 32-bit JDK 7u5.

The latest upgrade to Stash 1.2.0 appears to have gone ok.

I'm suspecting it could be a VMware problem but right now I don't know what to do about it. I'm just hoping the server won't start crashing in between Stash updates.

I have raised the issue with Atlassian support.

One thing that we noticed is that the BSODs seem sensitive to the VMware coresPerCpu setting. Our VM is allocated 8 virtual CPUs and we've tried running with the following configurations:

A. 1 socket with 8 cores per socket
B. 4 sockets with 2 cores per socket
C. 8 sockets with 1 core per socket

We can easily get the machine to crash in configurations A and B by running a script that replays some random clicking activity in Stash. Configuration C appears stable thus far but we're obviously very concerned whether it'll hold up in the long run.

Was this ever resolved, Lars?

I have the same issue running Stash 3.10.2 on Windows 2008 R2 in VMWare. My minidump results are nearly identical to yours.

Thanks,

Mike

Hi @Mike McGuire,

This was fixed in the past but there was a regression that affects your version. Upgrading to at least 3.10.4 should fix this. See https://jira.atlassian.com/browse/BSERV-7620

 

Cheers,

Stefan

I'm getting the exact same error under essentialy the same conditions.

Are you also running Crucible / FishEye on the same server?

I am running FishEye but not Crucible on the same server. I disabled Stash for the time being and have not had a chance to try 1.2.0 yet as Lars-Erik suggests below. I have had the issue on both virtual and non-virtual servers.

Hey Guys,

This is pretty high on our priority list and we're actively investigating this issue; I'll have an update as soon as we find the cause/fix for this issue.

Regards,

Ajay Sridhar.

Atlassian Support.

Can confirm that this is occurring on a physical machine as well. I've also had Tomcat crash without a full Windows crash.

We have now also tested on a physical machine running 2008 R2 with the same result (BSOD). I guess VMware is off the hook.

Hey Guys,

We've managed to reproduce the BSOD locally on a Windows Server 2008 RC2 VM. Implementing the suggestions from the following Microsoft KB Article appears to prevent the BSOD from occurring in our environment:

http://support.microsoft.com/kb/2535804

We've also had positive reports from customers who implemented the fix.
Can you please try the KB and let us know if this fixes the BSOD?
We'd love to help! Please raise a support ticket on https://support.atlassian.com
Cheers,
Ajay.

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

683 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot