Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,465,489
Community Members
 
Community Events
176
Community Groups

Download Repository button doesnt work

Capture.PNGUser has admin permissions, but nothing downloads.

2 answers

1 accepted

0 votes
Answer accepted
Patrik S Atlassian Team Jan 10, 2023

Hello @Julie Sgroi ,

Thank you for reaching out to Atlassian Community! 

I tried to reproduce the issue in my own repository, but the download was successful. In this case, I would like to ask you the following : 

  • What is the browser that you are currently using, as well as its version? Have you tried a different browser and noticed the same behavior?
  • Would you mind trying to replicate the issue using your browser's Incognito/Private Mode? This might help us eliminate browser cache issues.
  • Is this happening for all users on your repository, or only for you?
  • Do you receive any error message when clicking on the Download repository button? If yes, could you share the message or screenshot of the error? 
  • Could you try downloading by accessing the repository > Clicking on Downloads section in the left panel > Select Download repository and see if the same error occurs? 

In case you have any questions, let me know!

Thank you, @Julie Sgroi 

Patrik S

Thanks for the reply Patrick. I've since learned that it's more an issue of downloading old commits. Is this possible?  In answer to your questions:

  • I tried Chrome and Microsoft Edge browsers initially and both had the same issue.
  • I just tried the incognito browser in chrome to the same effect
  • No error when clicking on the Download repository button- just doesn't work 
  • Using the downloads tab (from left menu) I can download the current repository.

Thank you. 

@Patrik S  Please see above.

Patrik S Atlassian Team Jan 10, 2023

Hey @Julie Sgroi ,

Thank you for providing the results of the testing.

Could you please clarify what you meant by downloading old commits? 

I'm assuming you are accessing the Source page of the repository in the UI and then clicking on the 3 dot icons and then Download Repository. Can you share the steps you are taking to try downloading an old commit and it doesn't work? 

Hi @Patrik S ,

From the Source page, under README.md, there's a list of previous Versions. Can these be accessed and downloaded?

Patrik S Atlassian Team Jan 11, 2023

Hello @Julie Sgroi ,

I'm s having trouble finding the list of previous versions you mentioned to be under README.md.

To help us understand where exactly you are trying to download the previous version, could you share some screenshots of all the steps you are following to get to this list of previous versions? 

Please make sure to mask any private content from the screenshot.

If you don't want to share screenshots of your private repository, you can create a repository for test purposes with the default README.md, reproduce the issue in this repository and share screenshots from that.

@Patrik S 

@jonathan.hein@icpms.com

Patrick- I misunderstood the issue.  The problem is downloading old commits. The following steps were followed: 

  Open the repository

  1. Click “Commits” on the left menu
  2. Browse to the commit I want to download and click the commit link, 
  3. Click “View source” button at the top right of the window (next to “Approve” button)
    1. This allows me to browse the old commit and files through the web UI.
  4. To download I click the button with three dots and click “Download repository”.
  5. At this point nothing happens. There’s no error message or anything.

 

Thanks for the help.

Patrik S Atlassian Team Jan 16, 2023

Hello @Julie Sgroi ,

Thank you for providing the steps. I was able to reproduce the issue following the steps you shared, so I raised a public bug for this issue, which you can find in the following link : 

I would suggest you to add your vote there, since this helps both developers and product managers to understand the impact. Also, make sure you add yourself as a watcher in case you want to receive first-hand updates from that ticket.

The current workaround would be to copy the commit hash from the URL and access the following download URL with the commit hash replacing the placeholder text :

https://bitbucket.org/<workspace-slug>/<repo-slug>/get/<commit-hash>.zip 

 Thank you, @Julie Sgroi !

Patrik S

0 votes

That has not been working for a long time. It is nowadays hard to use bitbucket.

Suggest an answer

Log in or Sign up to answer
DEPLOYMENT TYPE
CLOUD
PERMISSIONS LEVEL
Site Admin
TAGS

Atlassian Community Events