Cannot get "git clone .. " to work

This is my first attempt to use git and my first attempt to use bitbucket. My collaborator invited me to clone his repository and told me to use the command: 

git clone https://your-username@bitbucket.org/path_to_repository


But what username is expected? I have an Atlassian username, a github username, a username assigned by the command 

git config --global user.name "MyName"

or maybe some completely different username.

git then asks me for my password. Same question: which password? I have hundreds of them.

Maybe I should be asking a meta-question. How do I get started?

1 answer

0 vote

It should be your Atlassian username and password.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jun 12, 2018 in Bitbucket

Do you use any Atlassian products for your personal projects?

After spinning my wheels trying to get organized enough to write a book for National Novel Writing Month (NaNoWriMo) I took my affinity for Atlassian products from my work life and decided to tr...

22,544 views 26 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you