Cannot get "git clone .. " to work

This is my first attempt to use git and my first attempt to use bitbucket. My collaborator invited me to clone his repository and told me to use the command: 

git clone https://your-username@bitbucket.org/path_to_repository


But what username is expected? I have an Atlassian username, a github username, a username assigned by the command 

git config --global user.name "MyName"

or maybe some completely different username.

git then asks me for my password. Same question: which password? I have hundreds of them.

Maybe I should be asking a meta-question. How do I get started?

1 answer

0 votes

It should be your Atlassian username and password.

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

663 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot