Can't push to my repo after latest update of sourcetree

I've just updated yesterday to new version and today I can't push to my repo.

 

Here is error I get:

https://i.imgur.com/p9m7OvM.png

 

It says that two-step-auth is enabled, well it's been enabled for last 6 months, I have not changed anything and was able to push 22 hours ago, but then I updated sourcetree with new version and now I can't push.

 

My account is set to use SSH: 

https://i.imgur.com/lEEfMVx.png

 

What seems to be the problem here?

Also If I switch to https and generate app password, I can't find anywhere where to input this app password.

thanks for any answers to help me figure this out.

 

 

1 answer

1 accepted

Accepted Answer
0 votes

Hi Nermion! It could be that some of the settings went corrupt, can you try wiping SourceTree preferences?  Then you can check Tools > Options > Authentication, make sure the right credentials are there and delete erroneous items.

If after that you're still getting errors, we'll need more information in order to troubleshoot this issue for you:

  • Does it work if you try to push using Git in the command line? 
  • Which SourceTree version and OS are you using.
  • Can you log in to your Bitbucket account using the web UI?

Regards,

Ana

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Aug 21, 2018 in Bitbucket

Branch Management with Bitbucket

As a project manager, I have discovered that different developers want to bring their previous branching method with them when they join the team. Some developers are used to performing individual wo...

2,367 views 9 12
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you