Can´t fetch or push to remote repository using sourceTree and Stash

Suddenly several of our developers can fetch or push to the remote repository.

It has worked before and is still working for other developers.

They get permission denied (public key). fatal could not read from the remote repository

This is strange as it has worked for them before

Any advice how to solve the problem

3 answers

1 accepted

This was caused by problems with ssh keys. Now we use http instead

"permission denied (public key)" means the server is rejecting their connection. Their could be a number of reasons. Check for typos. Verify that you have a private key generated and loaded into ssh: 'ssh add -l'. If that command does not print anything, you will need to load an existing SSH key by running 'ssh-add path/to/key'

0 vote

Hi Annicka,

I'd advise you to open a support request at https://support.atlassian.comand create and upload a support zip (Administration > Support Tools > Support Zip). That will allow our support engineers to have a look at your logs and sort out what might have gone wrong.

Cheers,

Michael

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jun 12, 2018 in Bitbucket

Do you use any Atlassian products for your personal projects?

After spinning my wheels trying to get organized enough to write a book for National Novel Writing Month (NaNoWriMo) I took my affinity for Atlassian products from my work life and decided to tr...

28,560 views 26 12
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you