Can't access ssh after installing stash

Hi

We are running opensuse 11.2, and git 1.8.3.We are team of 4 devs. I usually manage repo on server.

Pre Stash install

There was bare repo at /var/git/project.git which was cloned to each dev's machine. the real project was at /srv/htdocs. Everybody pushed to bare repo and it was me who pulled to /srv/htdocs. All was working fine but one day, after pushing to bare repo, another dev pulled to /srv/htdocs and he got error about permission. While investigating the issue I came across suggestion that I should install gitolite or stash. Stash fely bit more user friendly.

Stash Installation

I followed the steps to install stash. I first installed it on windows machine to get the idea about installation steps. After finishing install on linux machine I created users and repos. Successfully cloned the repo as well. For testing I did change soem comments and pushed. All worked fine. I was happy.

Post Install

My happiness was very short lived. I got call from other dev around 20 min later that he can't access mysql db. We were accessing db over ssh.

At first I thought may be sshd stopped but was surprised to see that it was running fine. so I used

$ssh -vv user@domain

and got server refused to start shell.

It had never happened before. So I checked /etc/sshd_config, which seemed to be fine. Then it came my mind that may be stash has in built ssh server which is conflicting with system sshd.

I checked STASH_HOME/log/catalina.out and found that it does have internal ssh server.

Now my probelm is how to resolve this conflict? I can't even start system sshd after stopping it. I always get 'failed' message.

Please let me know what to do. Am I doing something wrong in above scenario? If I must have to use stash ssh server then how can I enable shell access and where I can configure other settings?

or

How can I safely uninstall stash and start from sctach again?

Thanks for your time

PS: Let me know if you need more info[logs] to better investigate the issue.

2 answers

1 accepted

Hi Raminder,

That doesn't sound good. Do you mind creating a support ticket and attaching the logs in $STASH_HOME/log so we can diagnose the problem further?

Cheers,

Charles

Hi

I have just restarted the server and now got following error but good news is system ssh is running again

A fatal error has occurred

The following problem occurred which prevents Atlassian Stash from starting correctly:

    The Spring WebApplicationContext could not be started

Thanks for reply.

another update

I created new user git and chown all stash and stash-home dir to git user. file permissions for both dir are 775.

started stash as user git and it seems to work fine. my next question is how to change to https and how to remove ports from url? I tried to do it by reading documentation but it did't work.

Should I create a new question for it?

Thanks

Hi Raminder,

So you want to change the port that Stash is running on?

You can easily just change the default port that Stash is binding to, but if you want to use he default 80/443 ports you will need to run as root, which is _definitely_ not recommended.

You might want to think about running Stash behind a reverse-proxy. Have you seen this documentation?

https://confluence.atlassian.com/display/STASH/Integrating+Stash+with+Apache+HTTP+Server

Cheers,

Charles

Thanks Charles

This is the guide which I needed for setup.

I'll setup first on dev machine for test and then port to production.

If anything goes wrong, I'll be back here.

Thanks again for your help

Hi Raminder,

I'm sorry to hear that, although I'm not sure that Stash's SSH server will be affecting sshd - we are most likely binding to another port (7779 by default). Stash shouldn't be running as root so I can't see how it would have permissions to bind to port 22 in the first place?

In any case please raise a support ticket and attach all your logs, including any failure messages from sshd, so we can diagnose the problem further.

Cheers,

Charles

In addition you can stop Stash's SSH by going to the Adminstration -> Server Settings, although I'm not sure that's going to help.

Suggest an answer

Log in or Sign up to answer
How to earn badges on the Atlassian Community

How to earn badges on the Atlassian Community

Badges are a great way to show off community activity, whether you’re a newbie or a Champion.

Learn more
Community showcase
Posted Jun 12, 2018 in Bitbucket

Do you use any Atlassian products for your personal projects?

After spinning my wheels trying to get organized enough to write a book for National Novel Writing Month (NaNoWriMo) I took my affinity for Atlassian products from my work life and decided to tr...

174 views 20 8
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you