Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Celebration

Earn badges and make progress

You're on your way to the next level! Join the Kudos program to earn points and save your progress.

Deleted user Avatar
Deleted user

Level 1: Seed

25 / 150 points

Next: Root

Avatar

1 badge earned

Collect

Participate in fun challenges

Challenges come and go, but your rewards stay with you. Do more to earn more!

Challenges
Coins

Gift kudos to your peers

What goes around comes around! Share the love by gifting kudos to your peers.

Recognition
Ribbon

Rise up in the ranks

Keep earning points to reach the top of the leaderboard. It resets every quarter so you always have a chance!

Leaderboard

Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,456,338
Community Members
 
Community Events
176
Community Groups

Bitbucket stoped working after reinstallation of Jira

We are having a great deal of trouble to import a cloud site with +800 issues to our local server install of jira.

At the advice of the jira support people our IT dep. reinstalled the jira server, unfortunately we are still having the same issues.

 

But to make things worse our Bitbucket server stopped working too!

When trying to access the sever all we get are 404 and 500 error messages. Something related to "cwd_app_dir_mapping".


This seems to be an issue with the userdirectory, that was configured to use jira previously but still has two admin users in it's own primary userdirectory.

I tried resolution as stated:
https://confluence.atlassian.com/bitbucketserverkb/bitbucket-server-displays-404-j_bitbucket_security_check-after-user-directory-modifications-779171428.html

But the "cwd_app_dir_mapping" seems ok. See attached image of query

 

 cwd_app_dir_mapping.jpg

We also tried starting with a recovery password but that also seems to fail.

 

 

1 answer

1 accepted

0 votes
Answer accepted

The issue was finally resolved. Adding the solution here for other peoples reference.

 

During re-instalaltion of Jira the database user for jira was re-created with a different password than the previous installation.

When Bitbucket was installed the same database user was used for Jira and Bitbucket. So the database user in the Bitbucket.properties file of the Bitbiucket server still pointed to the correct database user but the password was in correct.

After we shut down the Bitbucket server, changed the password in the bitbucket.properties file and restarted the server again, we could login and re-instate the link to the Jira user directory.

Suggest an answer

Log in or Sign up to answer
TAGS

Atlassian Community Events