Bitbucket server triggers a Jenkins Job but the default parameters are not used

Hi,

We have Stash (Bitbucket Server) installed with the  "Stash Webhook to Jenkins" plugin installed.

I have a job that is being triggered correctly, however if a job has a parameter it is never used in the build.

To verify, after a build is finished, click on the build number, then click on "Parameters" but no parameters will be defined.

This works correctly, when the job is polled and or manually triggered. 

Thanks in advance for your help.

Joe.

1 answer

Same  issue here is it blocking a  lot of work

Suggest an answer

Log in or Join to answer
Community showcase
Piotr Plewa
Published Dec 27, 2017 in Bitbucket

Recipe: Deploying AWS Lambda functions with Bitbucket Pipelines

Bitbucket Pipelines helps me manage and automate a number of serverless deployments to AWS Lambda and this is how I do it. I'm building Node.js Lambda functions using node-lambda&nbsp...

699 views 0 4
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot