Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Bitbucket pipeline settings gone

Andrew Bailey February 8, 2023

I've transferred a repository from one workspace/project to another. In the old workspace, pipelines were working fine. In the new one, I go to the project's pipelines area, and there's a message saying "Pipelines is currently disabled for this repository. Enable it in the settings to start building again." with a link to go to settings. I click the link, but get a 404 "Resource not found" error. I manually navigate to the repository settings page, and there's not a pipelines section like there used to be. It's just gone! The new workspace is on a new free plan with 0 build minutes used and 50 remaining. I don't see any other settings page that would enable pipelines, and I need to know what steps to take to use pipelines again.

3 answers

1 accepted

2 votes
Answer accepted
Andrew Bailey February 8, 2023

The settings have appeared after about 2 hours.

0 votes
Ben Steel March 16, 2023

I also have the same problem from exactly the same steps.  Repository was transferred two whole days ago and the pipelines section is still missing. 

Ben Steel March 16, 2023

I was able to fix the issue by going to the project pipelines setting for a different repository (that did not have this issue) then changing the url.

 

So if repo good-repo worked fine, and repo problem-repo had the issue I copied the url from the good repo https://bitbucket.org/<workspace>/good-repo/admin/addon/admin/pipelines/settings and swapped it to https://bitbucket.org/<workspace>/problem-repo/admin/addon/admin/pipelines/settings and suddenly the settings page appeared.

0 votes
miloban February 23, 2023

I have the same problem, for me it is still not appearing since yesterday...

Suggest an answer

Log in or Sign up to answer
TAGS
AUG Leaders

Atlassian Community Events