Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bitbucket and Jira not working on Firefox/Linux

Hello! I'm not sure if this question has been asked before, but since about 5 days, Bitbucket and Jira webpages don't load on my browser. I'm using Mozilla Firefox under Linux Mint Tessa. Every time I try to load one of these pages, they stay blank, but if I load them on Firefox/Windows10, they load normally.

Since my working environment is on a Linux Virtual Machine, I want to know if there's something to help me solve this issue, because I need to keep track of the repo I'm working on besides the Git CLI and it's not efficient for me to switch between OS to just check these pages (Only 8GB of RAM, my ram suffers every time I open Firefox on either system). I've tried refreshing cache, logging out and in and nothing happens.

 

Thanks in advance for your help!!

5 answers

0 votes
Ana Retamal Atlassian Team Apr 29, 2019

Hi Raquel, welcome!

If my understanding is correct you're using Linux in the same machine you're using Windows, via a VM, is this right? I'm assuming that before that, Bitbucket and Jira were loading with no issues. To help you troubleshoot this issue, can you let us know the following?:

  1. Do you get any error or do the pages keep loading forever?
  2. Do other websites load?
  3. Which version of Mozilla Firefox are you using?
  4. Have you tried different browsers in the Linux part, like Google Chrome for example?
  5. Have you checked the developer tools in Mozilla Firefox? Do they show any additional information?

Looking forward to your response, Raquel. 

Best regards,

Ana

Hi Ana! Thanks for replying! Yes, you're right about the setup, and both pages were loading for at least two weeks in both systems when I created my accounts. Now, to answer your troubleshooting questions:

1.- No, the pages stop loading, but I get only a blank screen

2.- Other websites load, I can even get the Atlassian home screen to load, but when I try to see my projects on Jira or Bitbucket, blank screen appears

3.- I'm using the latest version for Linux Mint, which is 64.0

4.- Yes, I'm currently using Google Chrome since I made this post, and the pages work in that browser. It's just that Chrome is very resource-demanding for my VM and I try to avoid using it in there.

5.- I've checked the Firefox Dev tools, and the console gives me 2 messages from Bitbucket:

  • TypeError: "this.storage is undefined"
  • Unhandled promise rejection

And from Jira, it shows some JS libraries deprecated, errors about file corruption and the same Unhandled promise rejection.

I'll try to update my Firefox browser to see if something changes :)

Like Raquel Escalante likes this

same problem login fierfox under linux

in console see

request block https://aid-static-assets.prod.atl-paas.net/atlassian-id/14.6.9/fonts/CircularPro-Bold.woff. (no header CORS «Access-Control-Allow-Origin»)

It's not working for me on Firefox on Mac

error.png

Same for me. I found a temporary workaround, described here <https://davidjb.com/blog/2017/11/resolving-an-ns_error_file_corrupted-error-in-mozilla-firefox/>. In a nutshell, from a Tools/Web Developer/Web Console:

localStorage.clear()
sessionStorage.clear()

Then reload the page. Works for a short while before the problem occurs again. Jira is basically broken on Firefox.
0 votes
bpsib I'm New Here Oct 19, 2020

I also get this problem in Firefox but on Windows 10. Bitbucket just spins forever. I get

Uncaught TypeError: parcelRequire.registerBundle is not a function

errors in the console. Yet it loads straight away in Edge and Chrome.

prinia.png

-- oops, not an answer but need to open a bug

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bitbucket

Calling any interview participants for Bitbucket Data Center

Hi everyone,  We are looking to learn more about development teams’ workflows and pain points, especially around DevOps, integrations, administration, scale, security, and the related challeng...

441 views 4 4
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you