Bitbucket-Pipeline not cloning all branches Edited

Bitbucket Pipelines Cloning Pattern.png

I have implemented pipelines and configured my pipeline to have one custom pipeline and one on the master branch.

When the auto trigger branch pipeline runs, it just clones the branch which triggers the pipeline. But I need other branches as well to do git diff and get the delta changes. As a workaround I have to clone the entire repository again and checkout the branches which I need for my diff.

On the other hand if I run the pipeline manually though the custom pipeline. It clones all the branches.

Please find attached the screenshot from the 2 builds.

Is there any settings on pipelines to clone the entire repository?

 

Thanks

Anupama

0 answers

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Nov 06, 2018 in Bitbucket

Upgrade Best Practices

Hello! My name is Mark Askew and I am a Premier Support Engineer for products Bitbucket Server/Data Center, Fisheye & Crucible. Today, I want to bring the discussion that Jennifer, Matt, and ...

679 views 5 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you