Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bitbucket Connection Refused: 443

I am trying to clone a bitbucket repository from my CentOS7 machine. I followed the Link to solve the issue, but no solution is working. 

The command I am trying to run is:

     git clone 

and the Error I am getting is:

     fatal: unable to access ' /': Failed connect to; Connection refused


Can somebody please help me with the solution.

Is there anything be done from firewall side? 


1 answer

0 votes
Ana Retamal Atlassian Team Feb 07, 2018

Hi Vinay! If you have firewall blocking IPv6 traffic, you may need to update the firewall config to permit our IPv6 addresses, you can read What are the Bitbucket Cloud IP addresses I should use? for more info. Otherwise, if that's not possible, adding to your hosts' file could also work as an alternative workaround which will force your machine to use our IPv4 address instead.

You may follow this guide to add it to your hosts' file.

You can also read the comments at if you need more ideas.

Hope that helps!


Hi Ana,

I followed the link you asked me to, did following:

> Added into the hosts file. But No help.

> Added host route entry for and, then I could ping the following is the result:

     [root@localhost siteadmin-xvelocity-ui]# ping
     PING ( 56(84) bytes of data.
     64 bytes from localhost ( icmp_seq=1 ttl=64 time=0.122 ms
     64 bytes from localhost ( icmp_seq=2 ttl=64 time=0.083 ms

But when I am trying to clone a bitbucket repository, I am getting following error msg:


     Cloning into 'Dev_integration1'...

     fatal: unable to access ' /': Failed connect to; Connection refused

I have the exact same issue. I made the same hosts file change and I still get the same error message.

Like Rafael Lopes Fonseca likes this

@YasirJawad  The issue was resolved. I had to whitelist all the IPs of bitbucket. that way it worked.

@Vinay Verma How were you able to whitelist all the IPs? Did you just add the IPv4 ranges to your hosts file?

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bitbucket

📣 Calling Bitbucket Data Center customers to participate in research

Hi everyone, Are you Bitbucket DC customer? If so, we'd love to talk to you! Our team wants to dive deep to understand your long-term plans regarding Bitbucket DC and Atlassian Cloud. Do you plan...

79 views 2 3
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you