Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Transfer JAR between pipeline steps

Hi fellows! Please help with the error below?

I have a problem that my second step with Docker is not able to find the JAR produced in the first step. In my docker file I have:

Inside my Dockerfile:

COPY TEST.jar /inside/docker/dir/TEST.jar

Step 14/19: COPY TEST*.jar /inside/docker/dir/TEST.jar

ERROR: COPY failed: no source files were specified

My Configuration:

image: openjdk:11
- step:
name: Build jar
- gradle
- bash ./gradlew build
- "*.jar" //Here I have tried with: target/** , build/lib/**, **.jar -> Neither of them worked!!!
- step:
name: Build and publish docker image
- docker login --username $DOCKER_USER --password $DOCKER_PASSWORD
- docker build -t ***/test:latest .
- docker push ***/test:latest
docker: true


1 answer

did you find a solution to this after all?

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted in Trello

Taco Tuesday: Your favorite Trello blog takeaway

Hello friends! From the community that brought you Welcome Wednesday, Throwback Thursday and Friday Fun, welcome to Taco Tuesday, a weekly discussion about all things Trello. The best part? One Tac...

74 views 6 4
Join discussion

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you