batch script is not running when attempting to execute it thru a bamboo task Edited

When I run the following script thru powershell command prompt, it goes thru.  It copies the file from one machine to another.

$username = "xxxx@scilearn.com"
$password =  "yyyyyy"  | ConvertTo-SecureString -AsPlainText -Force
$creds = New-Object -TypeName System.Management.Automation.PSCredential -Argumentlist $username, $password

$sFileExecutable = "C:\bambooAutoScripts\copyWars.bat"
$out = Start-Process -FilePath "cmd.exe" -Credential $creds -ArgumentList ("/c $sFileExecutable")

  I am running it inline as a powershell script.   But when I have it inline in a bamboo task, it does nothing.  There are no error messages.  I have attempted to have the script file(s) in the bamboo working dir, but to no avail.

 

The contents of copyWars.bat is

copy C:\bambooAutoScripts\slc.war \\dc2qaodc03ap01.scilearn.com\d$\Storage\slc.war

 

 

 

0 answers

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,078 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot