Unable to get Maven version from /usr/share/maven/bin/mvn

When i run the image atlassian/bamboo-java-agent in my machine it produces the following error

  1.  Unable to get Maven version from /usr/share/maven/bin/mvn
  2. Could not find system variable. If you wish to use perforce please set the location as a capability.

How to solve these two errors

I later updated my maven to higher version 3.3 , but that is not reflected when i run the image as shown in the image.



Later i updated my maven to 3.3.3 but still when i run the Screenshot from 2015-11-05 00:17:25.png

1 answer

Suggest an answer

Log in or Sign up to answer
Atlassian Community Anniversary

Happy Anniversary, Atlassian Community!

This community is celebrating its one-year anniversary and Atlassian co-founder Mike Cannon-Brookes has all the feels.

Read more
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,359 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you