Come for the products,
stay for the community

The Atlassian Community can help you and your team get more value out of Atlassian products and practices.

Atlassian Community about banner
4,362,003
Community Members
 
Community Events
168
Community Groups

Powershell doesn't work in bamboo

Hello,

 

I have a powershell script that i tried on a with windows powershell console and it works, but when copied to bamboo it gives me an error: 

You cannot call a method on a null-valued expression.
 

This is the script i'm trying:

 

$command = "taskkill /F /IM myExe.exe"
$process = [WMICLASS]"\\10.1.0.2\ROOT\CIMV2:win32_process"
$result = $process.Create($command) 

 

ip and exe name are just examples.

 

I think the problem may come from  [WMICLASS] ?

 

any ideas?

1 answer

1 accepted

0 votes
Answer accepted
robhit Atlassian Team May 09, 2018

Hi,

I suspect these two commands are not getting any value to the variables:

$command = "taskkill /F /IM myExe.exe"
$process = [WMICLASS]"\\10.1.0.2\ROOT\CIMV2:win32_process"

Check what user is used to run the Bamboo or the Bamboo service and try to use that same user to execute these commands in PowerShell.

You could also try to echo the value of the variable before using it with the create method.

Thanks,

Robhit

Ok it worked, i tested once with the admin user and it didn't work event after restarting the service. After a while gave it another try and it worked... I have no idea why it works now tho

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 9.0 is now available

Hey there, Data Center community! I'm Martyna Wojtas and I am the Product Manager for Bamboo Data Center. I’m excited to share that Bamboo 9.0 is now available. We purpose-built this platform to help...

317 views 0 7
Read article

Atlassian Community Events