Page not found when opening Clover

When I try to open clover, PMD (plugin) and CheckStyle I get a "Page Not Found" error.

Clover url : http://rc-web1-p.c6.internebula.org:8085/browse/RC-ANA/aggregate?pluginKey=com.atlassian.bamboo.plugin.clover:Clover:${buildKey}

Any ideas ? I tried googling and searching here but I did not find a similar case.

3 answers

Not that it helps you but I am having exactly the same problem. It seems that the variable ${buildKey} isn't replaced by a real value.

I am having the same problem with Bamboo version 4.4.4, is it this bug? https://jira.atlassian.com/browse/BAM-11300 If so it has been in there a LONG time. What version are you running? Did you ever have a version plugin menu buttons worked in?

I'm still having this issue, at the plan level link. So, for example, going to the following url:

http://<jira-domain>/browse/<jira-plan>

has a link that doesn't work for me. I get the aforementioned error. However, when I go to the logs for a given build result, and click on a clover link, it works as expected. Example url is:

http://<jira-domain>/browse/<plan-name>-<job-number>-<build-number>/log

Suggest an answer

Log in or Sign up to answer
Community showcase
Published Jan 08, 2019 in Jira

How to Jira for designers

I’m a designer on the Jira team. For a long time, I’ve fielded questions from other designers about how they should be using Jira Software with their design team. I’ve also heard feedback from other ...

811 views 3 9
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you