Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

Next challenges

Recent achievements

  • Global
  • Personal

Recognition

  • Give kudos
  • Received
  • Given

Leaderboard

  • Global

Trophy case

Kudos (beta program)

Kudos logo

You've been invited into the Kudos (beta program) private group. Chat with others in the program, or give feedback to Atlassian.

View group

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

MSBild with Embarcadero Project

Hello,

I want to build a Embarcadero RadStudio C++ Project with Bamboo and MSBuild. When I compile the Project by command in Windows (on the Bamboo Server) (c:\Windows\Microsoft.NET\Framework\v3.5\msbuild.exe @d:\TEST-TES-JOB1-28-MsBuildTaskType-4805871277557311062.rsp), the compile is done without any Error. When I run it with Bamboo, it fails with a lot of errors that any headers from the Project can't be found. 

I Inside all needed path  additional with /p:AdditionalIncludePaths=<path>, but the error comes again.

Can anyone help me with this problem?

 

 

2 answers

0 votes
Jeyanthan I Atlassian Team Sep 13, 2017

Not sure what error you are getting. When you say that you are able to compile via command prompt, how about using Script task with interpreter as Windows Power Shell and add the respective set of commands inline?

Check if it works for you. If it doesn't, check the build log and compare it with the result of running manually. Also, compare the environment variables by running 'SET' on both command prompt and script task.

Thank you for your reply,

 

in the last days I test a lot of things. 

it works when I set this Enviremens in Bamboo:

ALLUSERSPROFILE="C:\ProgramData" APPDATA="C:\Users\user\AppData\Roaming"

and the Enviroments from the Borland Help:

http://docwiki.embarcadero.com/RADStudio/Tokyo/en/MSBuild

BDS="C:\Program Files (x86)\Embarcadero\Studio\19.0" FrameworkDir="C:\Windows\Microsoft.NET\Framework" FrameworkVersion="v3.5" FrameworkVersion="v3.5"

 

Another Problem was the property to Bild the Code:

I use this Option:s: /t:rebuild /p:Configuration=Debug, but it don't work. 

Now I make two task with this settings:

1st Task: /t:clean /p:Configuration=Debug

2nd Task: /t:build /p:Configuration=Debug

and it works. It works with Configuration Debug and Release

 

I think that is a Problem with the CodeGear.Cpp.Targets form Embarcadero.

Best Regards

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 7.1 is here and is packed with value!

I'm happy to announce that Bamboo 7.1 has been released and it’s overflowing with awesome new features. Top-voted issues First and foremost, a bunch of JAC top voted issues has been delivered - y...

696 views 1 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you