Launching Windows commands on remote agent

In Bamboo 5.1, I'm trying to configure a remote agent to run a build of a plan.

The remote agent successfully runs every task in the job, except the last one containing a simple Windows command to move a file ("move" Windows command configured in Bamboo as an executable).

I've tried to specify the command in several ways (with complete path or not) and then trying to use a different command (xcopy), but all the tries failed with the same error:

"Unable to find executable at move"


"Unable to find executable at xcopy"

What I'm missing or doing wrong?


1 answer

What is the syntax you are using? Are you trying to move the executable to a different location on the same target system or on a different one? One hint, Robocopy does a much better job of communicating errors than xcopy does.

Suggest an answer

Log in or Join to answer
Community showcase
Renan Battaglin
Published May 18, 2017 in Bamboo

FAQ: How to Upgrade Bamboo Server

Bamboo 5.9 will no longer be supported after June 12, 2017. What does this mean? As part of our End of Life policy, Atlassian supports major versions for two years after the first major iteratio...

1,096 views 0 5
Read article

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you
Atlassian Team Tour

Join us on the Team Tour

We're bringing product updates and pro tips on teamwork to ten cities around the world.

Save your spot