It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

High Bamboo CPU usage after upgrade from 5.6.0 to 5.8.1

In the last month we upgraded our Bamboo server from 5.6.0 to 5.8.1, and the engineering staff has been complaining about slower performance ever since. Getting to deployment plans has started taking a particularly long time

Our server is quad-core 2.2G Xeon with 16G of RAM, well within spec according to the documentation.

Nagios monitoring shows CPU load has gone up by about 30% and CPU I/O utilization similarly since the upgrade. Memory use isn't even close to the warning line. Usage hasn't changed much.  Restarting the service helps briefly. A tour of the logs hasn't turned up out of memory errors or anything else immediately suspicious. 

Is there something about the new version of Bamboo which predisposes it to higher CPU utilization? If not, what can be done to diagnose and fix the problem?

 

Thanks in advance,

Todd

1 answer

0 votes

Todd, there could be multiple reasons for that. Please contact our Support to investigate/resolve this issue.

Suggest an answer

Log in or Sign up to answer
Community showcase
Published in Bamboo

Unable to add or edit Bitbucket Cloud repository in Bamboo

On 31 May, a GDPR-related change went live in the Bitbucket Cloud API that resulted in users not being able to create or edit Bitbucket Cloud Linked repositories in Bamboo. This API update removed t...

691 views 2 7
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you