Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in
Deleted user
0 / 0 points
Next:
badges earned

Your Points Tracker
Challenges
Leaderboard
  • Global
  • Feed

Badge for your thoughts?

You're enrolled in our new beta rewards program. Join our group to get the inside scoop and share your feedback.

Join group
Recognition
Give the gift of kudos
You have 0 kudos available to give
Who do you want to recognize?
Why do you want to recognize them?
Kudos
Great job appreciating your peers!
Check back soon to give more kudos.

Past Kudos Given
No kudos given
You haven't given any kudos yet. Share the love above and you'll see it here.

It's not the same without you

Join the community to find out what other Atlassian users are discussing, debating and creating.

Atlassian Community Hero Image Collage

Bamboo shared credentials, missing SSH option Edited

Following your article here, I should be able to save the private key, however I only have the option of AWS.

 

Does anyone have any idea of what I need to do to enable the SSH option?

 

We are using Bamboo Server (On premise) version  6.6.1 build 60605 - 04 Jul 18

 

Thanks

1 answer

1 vote

Hello Adrian,

  • Have you added the SSH key at Cog >> Overview >> Shared credentials?
  • Can you share where you are trying to use the SSH key, in what task?

Hi @Daniel Santos,

Thanks for your reply,

This is my issue, under Cog >> Overview >> Shared credentials, there is no `SSH` option:

Bamboo-SharedCreds.png

I'm trying to add the shared SSH key, so that I can use it in tasks.

 

Many thanks 

It looks like the plugin Shared Credentials is disabled in your instance.

I was able to reproduce the same scenario by disabling its two modules:

  • SSH (sshCredentials)
  • Username and password (usernamePasswordCredentials)

Moving forward

  1. Try to enable the modules again:
    1. Admin page >> Manage add-ons
    2. Select All add-ons in the drop down
    3. Search for Shared Credentials
    4. Click add-on and then X of 2 modules enabled
    5. Click enable on each module disabled if there are any
  2. If you cannot enable the modules using the method above or if they show up as enabled, please try to restart the instance and check if this issue was fixed. It is possible that this issue was caused by a startup issue when loading the system add-ons.

In case this didn't help we will probably need to open a support case to investigate this further.

Suggest an answer

Log in or Sign up to answer
TAGS
Community showcase
Published in Bamboo

Bamboo 101 Video

G’day Community! As we gear up to introduce Bamboo Data Center to the world, we wanted to make sure that we shared a bit more about Bamboo, the product. Our team has put together an overview video ...

251 views 4 6
Read article

Community Events

Connect with like-minded Atlassian users at free events near you!

Find an event

Connect with like-minded Atlassian users at free events near you!

Unfortunately there are no Community Events near you at the moment.

Host an event

You're one step closer to meeting fellow Atlassian users at your local event. Learn more about Community Events

Events near you