Bamboo keeps starting builds on branches while the build plan is disabled

In Bamboo (v5.8.1) I've setup multiple Build Plans.

One of the build plans is disabled but the build is still triggered when a branch in the archive is created.

Resulting in build job I do not need ;-(

So:

  • Build plan is disabled,
  • Triggers in the in build plan is also disabled
  • "" is also disabled

How to resolve this?

P.s. in the end I managed to get if fixed by delete the link with the repository as well , but that seems a little far fetched to me.

1 answer

1 accepted

This widget could not be displayed.

Hello Mark,

Thank you for your question.

Disabling Plan(s) does not disable branch(es) created under the same Plan(s) configuration. In order to stop triggers, you need to visit branch(es) associated with the particular plan and disable it/them.

If you find this answer useful, I would kindly ask you to accept it so the same will be visible to others who might be facing the same issue you have inquired.

Thank you for your understanding.

Kind regards,
Rafael P. Sperafico
Atlassian Support

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

277 views 1 3
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you