Bamboo doesn't show all branches.

I am develop a framework and push it to our company's Nuget server. The thing is it doesn't build the correct feature branch. When I check all branches in our bamboo site, I am surprised that the branch is not there at all.

Say my current working feature branch is ISSP-163. See the image.

AllBranches.PNG

However please look at the bamboo, it is not there.

Branch-ISSP-79.PNG

I use visual studio to build the project. It has a gulpfile.js script.  If you need it, let me know please. By the way, I am not the bamboo administer.

1 answer

1 accepted

This widget could not be displayed.

Hi Hui,

Have you tried manually adding a Plan Branch?

Please refer to the documentation below for more details:

Best regards,
Thiago Bomfim

Bit of explanation: list displayed in Bamboo is a list of Plan Branches - entities created in Bamboo for remote branches in git repository while first screenshots shows list of branches defined in remote giot repository.

Suggest an answer

Log in or Sign up to answer
Community showcase
Posted Tuesday in Jira

What modern development practices are at the heart of how your team delivers software?

Hey Community mates! Claire here from the Software Product Marketing team. We all know software development changes rapidly, and it's often tough to keep up. But from our research, we've found the h...

305 views 1 4
Join discussion

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you