Bamboo build is not queued, waiting for not existing stages

Hi, I'm evaluating Bamboo and it makes me some troubles: Builds are not starting and seem to be waiting forever.

Some Info:

  • I configured two local agents, both are capable of running the build.
  • The plan has a single stage "Build" with two tasks: Checkout and call msbuild with my solution file.

When I manually select 'Run' it is queued and 'waiting to be build' forever. When clicking onto it, and selecting the only stage with the hourglass besides it from the sidebar, it tells me this status:

Status: Job has not yet been queued. Waiting for prior stages to complete.

I am totally lost now. How can I start the build? There are no prior stages that could be completed, because the checkout and build is the only one.

3 answers

Hello Sebastian,

Can you share a screenshot of your plan's configuration page(s) ? I can't find anything wrong in your description, so probably the devil is in the details... Also, is there something unexpected in the atlassian-bamboo.log file (you should have it somewhere in your BAMBOO/logs directory)? Maybe you should consider raising an issue on https://support.atlassian.com - I reckon Atlassian support engineers are helpful during evaluations of our products (including Bamboo).

regards,

0 votes

Status: Job has not yet been queued. Waiting for prior stages to complete.

I think this is only a display issue, so don't worry about it for now.

Could you check Agent Matrix (in Administration) to see if your agents can build your plan?

It's not a display issues. Both configured agents are capable of running the build, and both are idle.

Now, this morning the build was executed. It ran about 3 hours after I clicked 'run' on the UI. Is it normal that I trigger a build and wait hours long with both agents idle to have the build start?

No, it's not normal.

Unless - for example - Bamboo is doing initial clone of laaarge remote repository... hm... what kind of repository are you using? Could it be an issue, that you're using large (gigabytes) Git or Hg repository?

I'm just evaluating the whole setup, so I use a private Bitbucket Git repo with two commits in it, the whole repo size under 50 kilobytes. I'm pretty sure that this is not the issue ;-)

Interestingly, right now the builds are pretty instant. But there are no log entries showing why the previous builds were delayed so extremely.

How about "system errors" (Bamboo -> Administration -> System -> Sytem Errors)? Probably you won't have there anything right now, but if the problem would re-occur - can you check if there are some problems reported with getting changes for your plan using Git on Bitbucket?

Hello. I have similar problem. I run manual build and it hang without errors in "system errors" and logs. Executing first step of build not started.

I just connect to server by ssh and found processes, which recieve changes from github. I execute "kill -9" for this processes and restart build. After this build successfully started and executed without problems.

Suggest an answer

Log in or Sign up to answer
Community showcase
Asked Dec 06, 2018 in Jira Ops

I'm John Allspaw, Ask Me Anything about incident analysis and postmortems

I'm John Allspaw, co-founder of   Adaptive Capacity Labs, where we help teams use their incidents to learn and improve. We bring research-driven methods and approaches to drive effective inciden...

5,558 views 22 17
View question

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you