Bamboo - Could not load bootstrap from environment java.lang.NullPointerException

I upgraded Bamboo 5.4.2 to 5.8.1. 

While trying to resolve issues regarding remote agents not running. I tried instructions from this article:

https://confluence.atlassian.com/display/BAMKB/All+Bamboo+Remote+agents+cannot+connect+after+an+upgrade

After restarting several times, I can no longer make bamboo start. It gives me the attached screenshot.

err.PNG

 

2 answers

1 accepted

1 vote
Accepted answer

Thanks for raising a Support issue with us. Allow me to comment publicly here for future reference.

After looking into your logs we noticed the following stack trace:

2015-05-16 14:37:52,756 FATAL [localhost-startStop-1] [BootstrapLoaderListener] An error was encountered while bootstrapping Bamboo (see below): 
null
java.lang.NullPointerException
	at java.net.URLEncoder.encode(URLEncoder.java:205)
	at org.apache.activemq.util.URISupport.createQueryString(URISupport.java:505)
	at com.atlassian.bamboo.setup.BrokerURIUtils.reconstructCompositeUri(BrokerURIUtils.java:270)
	at com.atlassian.bamboo.setup.BrokerURIUtils.decorateBrokerURI(BrokerURIUtils.java:216)
	at com.atlassian.bamboo.setup.DefaultBootstrapManager.getBrokerClientURI(DefaultBootstrapManager.java:239)
	at com.atlassian.bamboo.setup.DefaultBootstrapManager.afterConfigurationLoaded(DefaultBootstrapManager.java:102)
	at com.atlassian.config.bootstrap.DefaultAtlassianBootstrapManager.init(DefaultAtlassianBootstrapManager.java:71)
	at com.atlassian.bamboo.setup.BootstrapLoaderListener.contextInitialized(BootstrapLoaderListener.java:95)
	at org.apache.catalina.core.StandardContext.listenerStart(StandardContext.java:4887)
	at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5381)
	at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:150)
	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1559)
	at org.apache.catalina.core.ContainerBase$StartChild.call(ContainerBase.java:1549)
	at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
	at java.util.concurrent.FutureTask.run(FutureTask.java:166)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:724)

What happened is that there was an invalid value for bamboo.jms.broker.client.uri. Once we fixed this, the application was back up and running.

We've written the following KB in case other customers need more details on this: 

Thank you!

Best,
Thiago Bomfim
DevTools Atlassian

 

 

1 vote

Can you please create request at support.atlassian.com?

And attach the logs.

Suggest an answer

Log in or Sign up to answer
Community showcase
Asked Dec 06, 2018 in Jira Ops

I'm John Allspaw, Ask Me Anything about incident analysis and postmortems

I'm John Allspaw, co-founder of   Adaptive Capacity Labs, where we help teams use their incidents to learn and improve. We bring research-driven methods and approaches to drive effective inciden...

5,569 views 22 17
View question

Atlassian User Groups

Connect with like-minded Atlassian users at free events near you!

Find a group

Connect with like-minded Atlassian users at free events near you!

Find my local user group

Unfortunately there are no AUG chapters near you at the moment.

Start an AUG

You're one step closer to meeting fellow Atlassian users at your local meet up. Learn more about AUGs

Groups near you