Create
cancel
Showing results for 
Search instead for 
Did you mean: 
Sign up Log in

[Atlassian account] Rest APIでメールアドレスを取得できない

事象

Rest APIを使用してユーザ情報を取得したところ、メールアドレスが取得できない。

 

原因

現状、アトラシアンアカウントのプロフィール設定の、[プロファイルと公開設定] にて、メールアドレスの公開範囲が「全員」となっているユーザーに対してのみ、Jira Cloud REST APIでEmail情報を取得する事が可能となっております。

 

対応

お手数ですが、公開範囲が「全員」以外となっているユーザーについては、UI上からユーザーのメールアドレスをご確認いただく必要がございます。

連絡先の公開範囲に関わらず管理者がREST API経由でメールアドレスを取得する機能につきましては、ほかのユーザー様から同様の要望をいただいており、下記の機能リクエストが起票されておりますが、恐れ入りますがまだ実現されておりません。

リンク先にて Vote for this issue(この課題に投票) していただくと機能が実現する可能性が高くなります。よろしければご検討ください。また、Start watching this issue(この課題をウォッチ) で購読していただくと、進捗があった場合にお客様に通知が送信されるようになります。

なお、機能開発の優先順位は、投票数のほかに製品戦略やフィードバックなども考慮して決定しております。詳しくは [新機能の実装ポリシー]をご覧ください。

0 comments

Comment

Log in or Sign up to comment
TAGS
AUG Leaders

Atlassian Community Events