We are using Jira Server deployed in AWS and we have deployed it behind an Application Load Balancer which allows both http and https.
We recently restarted our server due to high utilization.
When the server booted up, it started the jira app, but we can no longer access the jira dashboard.
Initially, we thought it was a Load Balancer issue so we disabled it and tried accessing jira via the IP. When we access the IP:8080, it gets redirected to https://IP:8443 which no longer works.
This was our server.xml settings before when we used Load Balancer:
<Connector port="8080"
maxThreads="150"
minSpareThreads="25"
connectionTimeout="20000"
enableLookups="false"
maxHttpHeaderSize="8192"
protocol="HTTP/1.1"
useBodyEncodingForURI="true"
redirectPort="8443"
acceptCount="100"
disableUploadTimeout="true"
bindOnInit="false"
scheme="https"
proxyName="jira.cloud.oleloapp.com"
proxyPort="443"
/>
<Connector port="8443" protocol="HTTP/1.1" SSLEnabled="true"
scheme="https" secure="true"
clientAuth="false" sslProtocol="TLS"
keystoreFile="conf/keystore" keystorePass="s00perSeeekrit"
/>
I disabled the Load Balancer and re-configured server.xml:
<Service name="Catalina">
<Connector port="8080"
maxThreads="150"
minSpareThreads="25"
connectionTimeout="20000"
enableLookups="false"
maxHttpHeaderSize="8192"
protocol="HTTP/1.1"
useBodyEncodingForURI="true"
redirectPort="8443"
acceptCount="100"
disableUploadTimeout="true"
bindOnInit="false"
Even when I remove redirectPort="8443", it still forces redirection to https.
Testing simulations...
[root@ip-172-31-31-159 conf]# curl -v localhost:8080
* Rebuilt URL to: localhost:8080/
* Trying 127.0.0.1...
* TCP_NODELAY set
* Connected to localhost (127.0.0.1) port 8080 (#0)
> GET / HTTP/1.1
> Host: localhost:8080
> User-Agent: curl/7.53.1
> Accept: */*
>
< HTTP/1.1 302
< Cache-Control: private
< Expires: Thu, 01 Jan 1970 00:00:00 UTC
< Location: https://localhost:8443/
< Content-Length: 0
< Date: Mon, 02 Apr 2018 08:11:19 GMT
<
* Connection #0 to host localhost left intact
[root@ip-172-31-31-159 conf]# curl -v https://localhost:8443
* Rebuilt URL to: https://localhost:8443/
* Trying 127.0.0.1...
* TCP_NODELAY set
* connect to 127.0.0.1 port 8443 failed: Connection refused
* Failed to connect to localhost port 8443: Connection refused
* Closing connection 0
curl: (7) Failed to connect to localhost port 8443: Connection refused