Newly created user cannot log in too many redirects. I even changed the rights to be an admin (and yes I included the base right to log in) and every time they login the browser errors out with the error "Too Many Redirects"
This also occurs when reactivating a user that was previously working but left our company and were deactivated.