Many of our users cannot access Stash at the moment. We suspect that the issue is related to JIRA groups because we recently made changes to allow external users to be in the system and only see one project.
What could be causing this error??
If you think it's related to groups, then you need to compare the Stash (Well Bitbucket now) settings for groups with the changes you have made.
we have 0 users that can access stash right now
I also work for Gramercy Tech. Here is the log that we are getting.
> The remote authentication server is not available
That answers the question - Bitbucket Server cannot reach the JIRA server to read the user details.
Hi Nic, I'm also from the same company.
We don't know what steps to take to resolve this issue. Can you list some steps that we could take to resolve this?
We went through all of the groups that we changed and there doesn't appear to be any errors involved there. Do you think this could be related to groups or something else? We thought it may be caused by groups originally but we're not sure that's the case any longer.
The log file says that Bitbucket cannot even *reach* the JIRA server to read the users. You need to fix that - it's either - A config error in Bitbucket - Your network not allowing the connection, - JIRA isn't running - JIRA is not allowing access to Bitbucket (I'm not sure you can do that with embedded Crowd)
Jira is cloud based. Stash (Bitbucket) is hosted. Stash was working just fine previously, and works fine for anyone who HAS NOT signed out. Once you sign out, you cannot sign back in without receiving this error. What is embedded Crowd? As far as I know we don't have access to, nor are using crowd.
The error message you've got is saying that Stash cannot connect to the user directory you have set up for it. At a glance, it looked like it was an embedded Crowd (that's the name for "An Atlassian application using a cut-down copy of Crowd internally to handle users) in JIRA, but re-reading the log, it might not be. Now you've said JIRA is Cloud based, that tells me a bit more. Your guess that changing JIRA groups is the problem is now a complete red-herring, because your Bitbucket Server won't be using Cloud JIRA for the user directories. You need to look at what user directory your Bitbucket Server is using and debug why it is unable to reach it over your network.
It looks like you're new here. Sign in or register to get started.