This happens every few days. We then need to go and re-auth Hubstaff again. After that things work fine for awhile.
Hubstaff engineers looked into the issue last time this happened and stated that the problem is on Jira's end:
"Our integration developer looked into this for you. He says that in order to be able to troubleshoot this further, you'll need to get in touch with Atlassian and get more information about what's happening from them, such as logs from of what URLs we are accessing that is triggering the error.
In case it helps them, here is the error that we're seeing on our end: 401: oauth_problem=nonce_used
Our developer looked into the cause of that error message, but the only result that he found would mean that all of our Jira integrations would be failing, and that's not the case. You seem to be the only person having regular authentication issues like this.
Please get in touch with Atlassian and convey to them everything that's happened, and ask them to provide some sort of logs about what URLs Hubstaff is accessing that's causing that error to appear. Thanks!"
Can somebody at Atlassian look into this and help please?
Thanks