We set up a few Mail Handlers in our onDemand account.
they worked for weeks with no issues.
we have not changed anything, and they stopped working.
the mail servers work you can test each account with no issues.
then when you test the handler it fails with no message or reason for the fail.
I have removed Handlers and tried to re-create them with no luck.



