I'm trying to configure the GitLab for Jira Cloud app to integrate our Jira instance with our self-hosted Gitlab.
I'm following the instructions here and think I've set up everything correctly, but when I try to get started with the app and click on "Sign in to <our Gitlab instance>" I get the message "Failed to load Jira Connect Application ID. Please try again."
With
curl --include "https://git.<domain>/-/jira_connect/oauth_application_id"
I get the correct application_id, both from inside our CN and from my personal network at home.
I've since learned that access to /api/v4/* is blocked in our Firewall for security reasons, so I suspect that is the culprit. I might be able to convince people to open this for a reasonable set of source IPs, hence my question:
Which IP ranges do I need to allow for the connection to work?