The provider tends to fail whenever the API rate limit is reached. Retry options seem to have no effect. I'd expect the provider to take multiple minutes to run instead of failing at the first error.
$ time terraform plan atlassian-operations_api_integration.prometheus: Refreshing state... [id=...] Planning failed. Terraform encountered an error while generating this plan. ╷ │ Error: Client Error │ │ with atlassian-operations_api_integration.prometheus, │ on main.tf line 1, in resource "atlassian-operations_api_integration" "prometheus": │ 1: resource "atlassian-operations_api_integration" "prometheus" { │ │ Unable to read api integration, status code: 429. Got response: {"message":"Too Many Requests"} ╵ terraform plan 0.19s user 0.07s system 77% cpu 0.340 total
https://github.com/atlassian/terraform-provider-atlassian-operations/issues/84
Hey Antoine,
You should probably create a support ticket for Atlassian for them to review and provide feedback.
https://support.atlassian.com/contact/#/
It looks like you're new here. Sign in or register to get started.