It turned out that the actor, Automation for Jira, did not have access to Forms (how strange). Changing it to my own user worked. Life is short, so I moved on. Thanks to Bill though.
Hi @Martin Cleaver
One possible cause of this symptom is the known racetrack timing problem with the Work Item Created trigger (among others). That is, the rule can start running before the work item data is fully available / stable for the rule to use, leading to incorrect conditions, actions, and weird errors...such as for permissions. Atlassian knows about the defect and is working on architectural changes to address it...but with no timeframe announced.
The workarounds / mitigations for this defect are:
Only the first one applies to your rule, so please try adding the re-fetch and re-testing your rule.
Kind regards,Bill
It looks like you're new here. Sign in or register to get started.