We have had several external users added to our system from the external domain. No one having User Access Admin role approved their access.
I've been able to find that for some reason their domain was white-listed for third-party sign up, but unable to find any specifics on how this domain was added and who initiated their access. The Audit logs are unavailabe - throwing an error when trying to access or export them.
I've created 2 support tickets but these tickets get resolved and marked as Spam.
I'm looking for the information on how this happened and how to prevent this from happening in the future.