As per the documentation, the following endpoint (/rest/api/latest/field), which is documented here, supports the 'id' query parameter, which is a list of one or more field IDs, comma-separated.
I am doing that, but instead of getting the two fields that I specified, I'm getting all the fields in our Jira instance. No error is returned.
It seems that the parameters 'startAt' and 'maxResults' are honored, but others (like 'id' and 'expand') are ignored.
If I use the endpoint /rest/api/latest/field/search, I get error 400 - bad request.
What am I doing wrong here?
Thanks