We are still using jira software server on our own docker swarm.
We restarted our jira today (in March, no more support).
Now our jira is not starting up and complains about our version being too new / license too old...
Version 9.12.2 was release in January, so well before the Support deadline, why is jira not starting up?
Backstory:
We now pinned the docker image to 9.12.2, but it was set to "latest" before and at one we started the "latest" container and it tried to run 9.14. Which did result in an error message. The we switched back to 9.12.2 (which seems to match our database schema version 91200002).
License Too Old For Build: We found a problem with your JIRA license
Your current Jira Software license doesn't allow you to upgrade to this version of JIRA (9.12.2). Jira Software expired on 14. Feb 2024 13:00, and you can currently only upgrade to versions released prior to this date. Alternatively you can renew your license at my.atlassian.com which will allow you to upgrade to this version of JIRA (9.12.2). You can enter your new license here.
See our documentation for more information on licensing errors.