I constantly receive an OAuth 2.0 error message when calling any endpoint of the servicedeskapi.
Example: "OAuth 2.0 is not enabled for method: GET /rest/servicedeskapi/servicedesk"
I've tried the older API and v2, but both return the same error. The scopes I'm using are "read:servicedesk-request", "manage:servicedesk-customer", "write:servicedesk-request", "offline_access"
Example requests below.
GET https://api.atlassian.com/ex/jira/{cloudId}/rest/servicedeskapi/request
H- Authorization: Bearer xxx
H- Accept: application/json
*Fails with OAuth 2 error
GET https://{myDomain}.atlassian.net/rest/servicedeskapi/request
-H Authorization: Bearer xx
-H Accept: application/json
*Fails with OAuth 2 error
Any ideas as to why these calls fail? As mentioned, all other calls fail, GET and POST on any endpoint.
For more context, this worked for a client until January 31st and suddenly began failing.