We are in the process of rolling out the Discovery Agent 3.2.0 in our environment through an RMM software. The Discovery Agent program/service installs correctly, runs scans on schedule and creates agent scan .dat files, but we are unable to set the agent token by running the Discovery_Agent.exe with the "-token" switch from the RMM tool. We receive the following error:

Cannot start service from the command line or a debugger. A Windows Service must first be installed (using installutil.exe) and then started with the ServerExplorer, Windows Services Administrative tool or the NET START command.
So far we have tried:
- Running the discovery_agent.exe -token command token as System, a local machine admin or a domain account with administrative permissions
- Manually installing the service using the installutil.exe from the .NET framework
- Running the service as NT Authority\Local Service, NT Authority\Network Service, System, a local admin account
- Manually setting parameters in the registry for the service
- Installing the latest version of the agent (3.2.1 as of now)
Has anyone else run into this issue when rolling out Discovery Agent 3.2.0?