I have Jira Service Management set up. Customers are able to submit requests and upload images/attachments through the Portal when first making a request. My help desk staff and administrators can reply with attachments and images in comments. If the Customer tries to upload an image or attachment in a comment, they get a gray box with "Failed to load". That seems like a permissions problem to me (if internal staff are able to upload fine), but I've double-checked all my permissions and they confirm that they allow uploading of attachments for "Service Project Customer - Portal Access" group/role. This happens across multiple users and browser types.
Also - I've made sure to disable the one add-on I have on my JIRA instance (JIRA spreadsheets connector) and that didn't solve the issue.
Any ideas?