I checked the settings in the notifications admin tool and it had checkmarks for all.
Notifications are not in my SPAM folder.
I suspect my domain and/or email address are blocked in some way as I have seen from other threads that a support engineer was able to run an email address through some tools and it came out rejected but when she removed the block things started to work...
Could I have someone do that for me as well?