I have a Confluence space with multiple pages, two of which fail to load. There is a group that I use to grant access to the space and me and the other user I'm working with both are members of the group and can see everything else in the space. However, when we navigate to the particular pages, there is a "You've stumbled on restricted content" message. And sometimes it also gives a "We've hit a snag. The issue should resolve on its own, but if it keeps happening, ask your admin to contact our support team..." I have also checked the page restrictions, and its currently set to "Anyone can view and edit."
Any suggestions for how to proceed? Do I just need to reach out to Atlassian Support, or this is something I can fix myself?