Hi,
My company is newly moving from Server to Cloud and many of the Scriptrunner JQL filters we use in server are not working in cloud. There are error messages which we have used to view documentation on what is supposed to be changed, but those items aren't working, either. In fact, even the example queries in the documentation (Many of which are written incorrectly with missing parens and such) don't even work.
The first filter I have uses the following on Jira Server to find all epics which have no assigned stories:
project = <project name> AND issuetype = Epic AND resolution = Unresolved AND issueFunction not in hasLinkType("Epic-Story Link") ORDER BY key ASC
When we run that on Cloud, we get the following error:
Your JQL includes the [hasLinkType] function from the [Adaptavist Scriptrunner] app for Jira Server. This function works differently in Jira Cloud. Refer to https://docs.adaptavist.com/sr4jc/latest/features/scriptrunner-jql-keywords-functions for details or contact the app provider.
So I go to that link and it indicates that now we should be using the "epicsOf" function to do what we want. In fact, they even have an example (with the wrong number of parens) which supposedly does this.
Jira Software users can also query on epic links to find all epics which do contain any issues.
project = <ProjectKeyHere> and issuetype = Epic and NOT (issueFunction in epicsOf("project = <ProjectKeyHere>")
Plugging it into Cloud, we get the following:
Your JQL includes the [epicsOf] function from the [Adaptavist Scriptrunner] app for Jira Server. This function works differently in Jira Cloud. Refer to https://docs.adaptavist.com/sr4jc/latest/features/scriptrunner-jql-keywords-functions for details or contact the app provider.
So this is saying we are using a Jira server function, even though this is the example we were directed to in the Cloud documentation!
So, thoughts?
Thanks,
Jeff