I've configured email integration in Opsgenie.
If I manually send an email, an alert is created as expected, however if I create a forwarding rule in Outlook for a specific email, the forwarded email delivery fails with:
Delivery has failed to these recipients or groups:
email1@_reducted_.opsgenie.net (email1@_reducted_.opsgenie.net)
Your message wasn't delivered because the recipient's email provider rejected it.