Hello Community,
I am using the default cloud Jira "new release" interface, on a Kanban project.
I am letting the default date format and it always gets rejected, it started at latest Monday 7th December (it was good on Monday 30th November)

I tried many format I could imagine but it's always getting rejected.
Did anyone experienced this issue ?
Thanks
Colin