when I use the rest api `/rest/api/2/issue/<issueId> ` it returns the error: server error 500 for some tickets, and for some other tickets it works fine.
Hi @Shweta_Oak
I think you will have to check the log files in order to find the root cause for this.
Links:
JIra log files location
Regards
Lasse Langhorn
Thanks for the answer @Lasse Langhorn ,
I discovered that the error is in the sprint return type:
as per this notice: https://developer.atlassian.com/cloud/jira/platform/deprecation-notice-tostring-representation-of-sprints-in-get-issue-response/,
the sprint type should be toString currently, however, until yesterday, the sprint type I was receiving was json, and now it is changed to the toString, which is why finding tickets with sprint fails and for tickets that dont have sprint, it works.
Any idea why this happened, and what is the work around?
It looks like you're new here. Sign in or register to get started.