While adding an email address, it showing DKIM validation failed for this domain.
Please help me with a detailed description.
Hi there,
Thank you for reaching out to Atlassian Community!
This error message appears when the domain of the email you are adding to the project is not verified, so in order to change the project email address, it's necessary to verify the domain.
Please, follow the steps of the documentation below:
If you have any questions or face any issue, please let us know.
Regards,Angélica
We have updated the DKIM file and verified also but it is still showing the same(DKIM validation failed for this domain).
Is it mandatory to add SPF in our records?
Yes, it's necessary to follow all steps in order to use the email as the project email address.
Hi Angelica,
We have updated all records as per your instructions. We are getting a new error that is, "
Unknown server error without description" after the update all records.
Please find attached a screenshot of the issue.
Please suggest us to resolve this issue.
Thanks
Bhanu
I'm having a similar issue. @Angélica Luz can you take a look?
Hello @Josh
Thank you for reaching out to Community!
Can you share with us the error that appears when you try to change the project email address?
I can see that the domain is correctly verified, so now it would be only necessary to follow the steps of the documentation below:
- Configuring Jira Cloud to send emails on behalf of your domain
The issue is in AWS Route53 has a record type on the DNS called "SPF"
To fix my issue I had to instead use a TXT record.
I would like to share one more issue with TXT SPF record validation. In DNS servers replies, large TXT records can be split on parts. I.e. in case you have long list of IPs, includes and related things, the result TXT record received from DNS server will be like this:
TXT "v=spf1 +a +mx +ip4:<MASKED IPv4> <MASKED LIST OF IPv4> +ip4:<MASKED IPv4> include:_s" "pf.atlassian.net ~all"
Let me highlight the issue in the example above:
+ip4:<MASKED IPv4> include:_s" "pf.atlassian.net
In such case, https://domain-check.atlassian.com/ will fail to validate presence of string "include:_spf.atlassian.net" in DNS server reply...what means that the logic of service has a bug: TXT records returned as a list of strings should be joined into single string.
I.e. the validation logic should convert DNS server reply provided above into the following string:
TXT "v=spf1 +a +mx +ip4:<MASKED IPv4> <MASKED LIST OF IPv4> +ip4:<MASKED IPv4> include:_spf.atlassian.net ~all"
The simplest way to solve the issue is to put "include:_spf.atlassian.net" at the start of SPF definition (right after "v=spf1" option).
It looks like you're new here. Sign in or register to get started.